Back to overview

Homeaware API (Internal) is down

Aug 25 at 09:58am CDT
Affected services
Ubiety Gateway (External)
Push Notifications API (Internal)
Homeaware API (Internal)
Presence HomeAware

Resolved
Oct 20 at 05:52am CDT

Service Outage - Multiple Services

Service: Multiple services

Severity: Degraded

Region: AWS US-EAST-1 (N. Virginia)

Contact: support@homeaware.com

Status: RESOLVED

Summary

HomeAware services experienced degraded performance and increased error rates due to a widespread AWS infrastructure issue affecting the US-EAST-1 region. The issue has been fully resolved.

Impact on HomeAware Services

  • Increased error rates and latencies across multiple services
  • Some users experienced timeouts and failed requests
  • New service deployments were temporarily affected
  • Overall service availability was maintained with degraded performance

Timeline

Oct 20, 12:00 PM PDT - RESOLVED - All services are now operating normally. The underlying AWS infrastructure issue has been fully resolved.

Oct 20, 11:22 AM PDT - IMPROVING - Significant improvements in service performance. Most services are recovering well.

Oct 20, 10:38 AM PDT - RECOVERING - Early signs of recovery across most services. Some areas still experiencing issues.

Oct 20, 9:13 AM PDT - INVESTIGATING - AWS has identified the root cause and is implementing fixes. Services beginning to stabilize.

Oct 20, 8:43 AM PDT - INVESTIGATING - Root cause identified as network connectivity issues. AWS is actively working on resolution.

Oct 20, 7:29 AM PDT - INVESTIGATING - Early signs of recovery detected. Continuing to monitor the situation.

Oct 20, 6:42 AM PDT - INVESTIGATING - Multiple mitigations applied. Some services showing improvement.

Oct 20, 5:48 AM PDT - INVESTIGATING - Progress being made on resolving the underlying issues. Some services recovering.

Oct 20, 4:48 AM PDT - INVESTIGATING - Working to restore full service functionality. Some services still affected.

Oct 20, 3:35 AM PDT - INVESTIGATING - Most services recovering, but some operations still experiencing issues.

Oct 20, 2:27 AM PDT - INVESTIGATING - Significant signs of recovery. Most requests now succeeding.

Oct 20, 1:26 AM PDT - INVESTIGATING - Confirmed widespread service issues. Engineers actively working on resolution.

Oct 20, 12:51 AM PDT - INVESTIGATING - Increased error rates and latencies detected across multiple services.

Oct 20, 12:11 AM PDT - INVESTIGATING - Initial detection of service issues. Investigation underway.

Current Status

RESOLVED - All HomeAware services are now operating normally. The underlying AWS infrastructure issue has been fully resolved.

What We Did

  • Monitored AWS Service Health Dashboard continuously
  • Implemented retry logic for failed requests
  • Communicated with users about the ongoing issue
  • Coordinated with AWS support for resolution

Prevention

  • Continue monitoring service health metrics
  • Maintain failover capabilities to other regions
  • Regular testing of disaster recovery procedures

Updated Oct 20 at 12:00pm PDT

Created
Aug 25 at 09:58am CDT

Homeaware API (Internal) recovered.